Problems with yamaha outboard | TigerDroppings.com
Posted by
Message
Tbooux
LSU Fan
Member since Oct 2011
1024 posts

Problems with yamaha outboard

I have a '04 Yamaha 150 2 stroke carburated, Last couple times I took her out when I went to jump up on step from idling she "spun out" and didn't have any power. First time or two just thought it might have been trash in the prop, but it's happened too often to be a coincidence. Thought it might be my prop bushing going out, but pulled it off and looks fine, anyone had simialr problems or any ideas on what it could be?


jaggedlp
LSU Fan
Member since Oct 2011
116 posts

re: Problems with yamaha outboard
Really sounds like a spun hub on prop. Sometimes they look ok but need o be changed


Tbooux
LSU Fan
Member since Oct 2011
1024 posts

re: Problems with yamaha outboard
quote:

Really sounds like a spun hub on prop. Sometimes they look ok but need o be changed


Thought the same but hub looks perfect, guess I will bring in to a shop just to be sure.

Just worried its a gearing problem that could turn into something major....


Da Hammer
LSU Fan
Folsom
Member since May 2008
3536 posts

re: Problems with yamaha outboard
Almost has to be your prop. Put your spare on and see if that fixes problem. Over the years I have only had one bad hub that I could see was bad when looking at it. The rest looked fine. Gears would likely be grinding and the motor wouldn't sound normal.


Replies (0)
Replies (0)
Page 1 of 1

Back to top

Follow TigerDroppings for LSU Football News
Follow us on Twitter, Facebook and Instagram to get the latest updates on LSU Football and Recruiting.

FacebookTwitterInstagram