menu
Posted by
Message
failuretocommunicate
LSU Fan
Lafayette
Member since Dec 2007
625 posts

go devil longtail problem

I have an 18hp vanguard briggs engine that powers my mud boat. last Friday after putting out decoys I hit a stump and the engine killed. Engine cannot/won't spin the prop now......seems to be frozen. I can't manually spin the prop either. I'm assuming I have a shaft problem (and not an engine issue).

OBers thoughts? I'm not much of a mechanic........any suggestions of someone in the Lafayette the might be familiar with these things?

TIA


Bussemer
LSU Fan
Heading South
Member since Dec 2007
2401 posts
Online

re: go devil longtail problem
Hit it with a hammer!

Seriously, try and spin the prop with a "soft" hammer. Happened to me before. If that doesn't work, take it to Coco, probably a bent/broken shaft


swelbo1
LSU Fan
Deridder
Member since Sep 2004
63 posts

re: go devil longtail problem
It's the magnets in he fly wheel. Got to take it to Coco. I had the same problem a few years ago.


failuretocommunicate
LSU Fan
Lafayette
Member since Dec 2007
625 posts

re: go devil longtail problem
magnets in flywheel doesn't sound good.

Who/where is coco? I'm not a regular to the OB



swelbo1
LSU Fan
Deridder
Member since Sep 2004
63 posts

re: go devil longtail problem
It's not that big of a deal. He's the owner of go devil in baton rouge.


Replies (0)
Replies (0)
first pageprev pagePage 1 of 1next pagelast page
refresh

Back to top

logoFollow TigerDroppings for LSU Football News
Follow us on Twitter, Facebook and Instagram to get the latest updates on LSU Football and Recruiting.

FacebookTwitterInstagram